summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb
new file mode 100644
index 0000000000..7b0d1a0696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.7.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
6SRC_URI[md5sum] = "f1b34c688ef7dccccb951130f008f6fe"
7SRC_URI[sha256sum] = "822f4605f28f7d2ba6b0b09a31e25e140871e96364d1d377667b547bb3bf4489"
8
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "prompt_toolkit"
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-terminal \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-wcwidth \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-shell \
21 ${PYTHON_PN}-image \
22"
23
24BBCLASSEXTEND = "native nativesdk"