diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb b/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb new file mode 100644 index 0000000000..3c770e41d3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "Protocol Buffers" | ||
2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" | ||
3 | SECTION = "devel/python" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | SRC_URI[sha256sum] = "57d65074b4f5baa4ab5da1605c02be90ac20c8b40fb137d6a8df9f416b0d0ce2" | ||
10 | |||
11 | # http://errors.yoctoproject.org/Errors/Details/184715/ | ||
12 | # Can't find required file: ../src/google/protobuf/descriptor.proto | ||
13 | CLEANBROKEN = "1" | ||
14 | |||
15 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" | ||
16 | |||
17 | DEPENDS += "protobuf" | ||
18 | |||
19 | RDEPENDS:${PN} += " \ | ||
20 | ${PYTHON_PN}-datetime \ | ||
21 | ${PYTHON_PN}-json \ | ||
22 | ${PYTHON_PN}-logging \ | ||
23 | ${PYTHON_PN}-netclient \ | ||
24 | ${PYTHON_PN}-numbers \ | ||
25 | ${PYTHON_PN}-pkgutil \ | ||
26 | ${PYTHON_PN}-six \ | ||
27 | ${PYTHON_PN}-unittest \ | ||
28 | " | ||
29 | |||
30 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) | ||
31 | BBCLASSEXTEND = "native nativesdk" | ||
32 | |||
33 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" | ||
34 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" | ||
35 | |||
36 | do_compile:prepend:class-native () { | ||
37 | export KOKORO_BUILD_NUMBER="1" | ||
38 | } | ||