summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb b/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
new file mode 100644
index 0000000000..cf3e0b39c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
4
5SRC_URI[sha256sum] = "869842dbd66bb80c3217158e629d6fceaecc3a3166d3d1faee515b05dd26ca25"
6
7inherit pypi setuptools3
8
9PACKAGES =+ "${PN}-tests"
10
11FILES:${PN}-tests += " \
12 ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
13 ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
14"
15
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-shell \
19 ${PYTHON_PN}-threading \
20 ${PYTHON_PN}-xml \
21 ${PYTHON_PN}-netclient \
22 ${PYTHON_PN}-ctypes \
23 ${PYTHON_PN}-resource \
24"
25
26BBCLASSEXTEND = "native nativesdk"