summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb
new file mode 100644
index 0000000000..1e97b27aed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.144.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "7dbaf665d9288f2a2692bee3d6207bb6abe3c51f"
8S = "${WORKDIR}/git"
9
10inherit setuptools3
11
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-jsonschema \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-six \
18 ${PYTHON_PN}-deprecated \
19 ${PYTHON_PN}-wrapt \
20"
21
22# Fixes: python3-pymisp requires /bin/bash, but no
23# providers found in RDEPENDS_python3-pymisp? [file-rdep]
24RDEPENDS_${PN} += "bash"