summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb
new file mode 100644
index 0000000000..2beff5c33d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.168.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "9a7adb2e0d60d2edee9f541db808652875bae20e"
8S = "${WORKDIR}/git"
9
10inherit python_poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-jsonschema \
18 ${PYTHON_PN}-requests \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-deprecated \
21 ${PYTHON_PN}-wrapt \
22"
23
24# Fixes: python3-pymisp requires /bin/bash, but no
25# providers found in RDEPENDS:python3-pymisp? [file-rdep]
26RDEPENDS:${PN} += "bash"