summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
new file mode 100644
index 0000000000..dcde77db08
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI[sha256sum] = "bdf2d54b297ad890418179b044dd4ea79821fccef723823919d12262e9794ca3"
7
8inherit python_poetry_core pypi
9
10PIP_INSTALL_PACKAGE = "pymisp"
11
12RDEPENDS:${PN} += " \
13 python3-dateutil \
14 python3-json \
15 python3-jsonschema \
16 python3-requests \
17 python3-six \
18 python3-deprecated \
19 python3-wrapt \
20"
21
22# Fixes: python3-pymisp requires /bin/bash, but no
23# providers found in RDEPENDS:python3-pymisp? [file-rdep]
24RDEPENDS:${PN} += "bash"