summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb
new file mode 100644
index 0000000000..cb28ec3ff9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.194.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI[sha256sum] = "f7adb929a0f8a7f0a7c8a9be7727db247a9a30f3525216747fdbca151eb0a44a"
7
8inherit python_poetry_core pypi
9
10RDEPENDS:${PN} += " \
11 python3-dateutil \
12 python3-json \
13 python3-jsonschema \
14 python3-requests \
15 python3-six \
16 python3-deprecated \
17 python3-wrapt \
18"
19
20# Fixes: python3-pymisp requires /bin/bash, but no
21# providers found in RDEPENDS:python3-pymisp? [file-rdep]
22RDEPENDS:${PN} += "bash"