summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb b/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb
new file mode 100644
index 0000000000..3750f5781e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=2c2223d66c7e674b40527b5a4c35bd76"
5DEPENDS += "python3-six-native"
6
7SRC_URI[sha256sum] = "714e5d6b7e28c4016a94346e73033aff276b6ce8bd22e470ba4fd8b982e08a98"
8S = "${WORKDIR}/pymodbus-${PV}"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
14PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
15PACKAGECONFIG[tornado] = ",,,python3-tornado"
16PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
17PACKAGECONFIG[redis] = ",,,python3-redis"
18PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
19
20RDEPENDS:${PN} += " \
21 python3-asyncio \
22 python3-core \
23 python3-io \
24 python3-json \
25 python3-logging \
26 python3-math \
27 python3-netserver \
28"
29
30RDEPENDS:${PN} += " \
31 python3-pyserial \
32 python3-six \
33"
34
35