summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb
new file mode 100644
index 0000000000..d8708f5e72
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyproj_3.6.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "a5b111865b3f0f8b77b3983f2fbe4dd6248fc09d3730295949977c8dcd988062"
12
13RDEPENDS:${PN} = " \
14 python3-certifi \
15 python3-compression \
16 python3-json \
17 python3-logging \
18 python3-profile \
19"
20
21export PROJ_INCDIR = "${STAGING_INCDIR}"
22export PROJ_LIBDIR = "${STAGING_LIBDIR}"
23export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."