summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
new file mode 100644
index 0000000000..69d74567c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Thin-wrapper around the mock package for easier use with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \
6"
7
8SRC_URI = " \
9 git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
10 file://run-ptest \
11"
12
13SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
14
15SRC_URI[sha256sum] = "fbbdb085ef7c252a326fd8cdcac0aa3b1333d8811f131bdcc701002e1be7ed4f"
16
17inherit setuptools3 ptest
18
19DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
20
21RDEPENDS:${PN} += " \
22 python3-asyncio \
23 python3-pytest \
24 python3-unittest \
25"
26
27S = "${WORKDIR}/git"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests ${D}${PTEST_PATH}/
32}