diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb new file mode 100644 index 0000000000..39a7614fc5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SUMMARY = "PyZMQ: Python bindings for ZMQ" | ||
2 | DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation." | ||
3 | HOMEPAGE = "http://zeromq.org/bindings:python" | ||
4 | LICENSE = "BSD-3-Clause & LGPL-3.0-only" | ||
5 | LIC_FILES_CHKSUM = "\ | ||
6 | file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \ | ||
7 | file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e \ | ||
8 | " | ||
9 | |||
10 | DEPENDS = "python3-packaging-native zeromq" | ||
11 | |||
12 | SRC_URI:append = " \ | ||
13 | file://club-rpath-out.patch \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | SRC_URI[sha256sum] = "f330a1a2c7f89fd4b0aa4dcb7bf50243bf1c8da9a2f1efc31daf57a2046b31f2" | ||
17 | |||
18 | inherit pypi pkgconfig python_setuptools_build_meta ptest | ||
19 | |||
20 | PACKAGES =+ "\ | ||
21 | ${PN}-test \ | ||
22 | " | ||
23 | |||
24 | FILES:${PN}-test += "\ | ||
25 | ${libdir}/${PYTHON_DIR}/site-packages/*/tests \ | ||
26 | " | ||
27 | |||
28 | RDEPENDS:${PN} += "\ | ||
29 | ${PYTHON_PN}-json \ | ||
30 | ${PYTHON_PN}-multiprocessing \ | ||
31 | " | ||
32 | |||
33 | RDEPENDS:${PN}-ptest += "\ | ||
34 | ${PN}-test \ | ||
35 | ${PYTHON_PN}-pytest \ | ||
36 | " | ||
37 | |||
38 | do_compile:prepend() { | ||
39 | echo [global] > ${S}/setup.cfg | ||
40 | echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg | ||
41 | echo have_sys_un_h = True >> ${S}/setup.cfg | ||
42 | echo skip_check_zmq = True >> ${S}/setup.cfg | ||
43 | echo libzmq_extension = False >> ${S}/setup.cfg | ||
44 | echo no_libzmq_extension = True >> ${S}/setup.cfg | ||
45 | } | ||
46 | |||
47 | do_install:append() { | ||
48 | sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json | ||
49 | sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json | ||
50 | } | ||
51 | |||
52 | do_install_ptest() { | ||
53 | install -d ${D}${PTEST_PATH}/tests | ||
54 | cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/ | ||
55 | } | ||