summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests_2.26.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.26.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
new file mode 100644
index 0000000000..95e6e1a6b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
5
6SRC_URI[sha256sum] = "b8aa58f8cf793ffd8782d3d8cb19e66ef36f7aba4353eec859e74678b01b07a7"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-email \
12 ${PYTHON_PN}-json \
13 ${PYTHON_PN}-ndg-httpsclient \
14 ${PYTHON_PN}-netserver \
15 ${PYTHON_PN}-pyasn1 \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-pysocks \
18 ${PYTHON_PN}-urllib3 \
19 ${PYTHON_PN}-chardet \
20 ${PYTHON_PN}-idna \
21"
22
23CVE_PRODUCT = "requests"
24
25BBCLASSEXTEND = "native nativesdk"