summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb b/meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb
new file mode 100644
index 0000000000..a40d047d72
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_4.1.3.bb
@@ -0,0 +1,30 @@
1SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14PYPI_PACKAGE_EXT = "zip"
15
16SRC_URI[sha256sum] = "d2675cbe3e5a4c90be3ddb61be3b88cc0d6ff503c298ad8f8a78aad14e71e886"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
27 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-numbers \
29 ${PYTHON_PN}-profile \
30"