summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
new file mode 100644
index 0000000000..da3130016a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=2ddf47d0ff1849bce3257ccbc1fd275c"
4HOMEPAGE="https://github.com/holgern/py-scrypt"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[sha256sum] = "bcf04257af12e6d52974d177a7b08e314b66f350a73f9b6f7b232d69a6a1e041"
9
10inherit pypi ptest setuptools3 dos2unix
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-ctypes \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
27}