summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sh_2.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sh_2.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sh_2.2.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sh_2.2.2.bb b/meta-python/recipes-devtools/python/python3-sh_2.2.2.bb
new file mode 100644
index 0000000000..a84017a393
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sh_2.2.2.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python subprocess replacement"
2HOMEPAGE = "https://github.com/amoffat/sh"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
5
6SRC_URI[sha256sum] = "653227a7c41a284ec5302173fbc044ee817c7bad5e6e4d8d55741b9aeb9eb65b"
7
8inherit pypi python_poetry_core
9
10RDEPENDS:${PN} += " \
11 python3-asyncio \
12 python3-codecs \
13 python3-compression \
14 python3-core \
15 python3-io \
16 python3-logging \
17 python3-resource \
18 python3-shell \
19 python3-terminal \
20 python3-threading \
21 python3-unixadmin \
22 python3-fcntl \
23"