summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb
new file mode 100644
index 0000000000..058d90bbef
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.36.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
6
7SRC_URI[sha256sum] = "7f2767680b6d2398aea7082e45a774b2b0767b5c8d8ffb9c8b683088ea9b29c5"
8
9inherit pypi python_setuptools_build_meta cython
10
11RDEPENDS:${PN} += " \
12 python3-asyncio \
13 python3-compression \
14 python3-json \
15 python3-logging \
16 python3-netclient \
17 python3-numbers \
18 python3-pickle \
19 python3-profile \
20 python3-threading \
21 python3-typing-extensions \
22"
23
24BBCLASSEXTEND = "native nativesdk"