summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb
new file mode 100644
index 0000000000..fd6853939e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.39.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=061025f14213ac2818ff353223d6eca6"
6
7SRC_URI[sha256sum] = "5d2d1fe548def3267b4c70a8568f108d1fed7cbbeccb9cc166e05af2abc25c22"
8
9inherit pypi python_setuptools_build_meta cython
10
11RDEPENDS:${PN} += " \
12 python3-asyncio \
13 python3-compression \
14 python3-json \
15 python3-logging \
16 python3-netclient \
17 python3-numbers \
18 python3-pickle \
19 python3-profile \
20 python3-threading \
21 python3-typing-extensions \
22"
23
24BBCLASSEXTEND = "native nativesdk"