summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch90
1 files changed, 75 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch b/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch
index ad6c50ff77..94121340d5 100644
--- a/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch
+++ b/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch
@@ -1,4 +1,4 @@
1From 10c9d3341d64d697f678a64ae707f6bda21565bb Mon Sep 17 00:00:00 2001 1From 7fd00ab8c1b663052d57e735b6b956d5c92fbaed Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com> 2From: Changqing Li <changqing.li@windriver.com>
3Date: Mon, 9 Mar 2020 13:10:37 +0800 3Date: Mon, 9 Mar 2020 13:10:37 +0800
4Subject: [PATCH] sqlparse: change shebang to python3 4Subject: [PATCH] sqlparse: change shebang to python3
@@ -10,42 +10,102 @@ we can only make this change after python2 is offcially
10dropped. 10dropped.
11 11
12Signed-off-by: Changqing Li <changqing.li@windriver.com> 12Signed-off-by: Changqing Li <changqing.li@windriver.com>
13Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
13--- 14---
14 setup.py | 2 +- 15 0001-sqlparse-change-shebang-to-python3.patch | 51 +++++++++++++++++++
15 sqlparse/__main__.py | 2 +- 16 setup.py | 2 +-
16 sqlparse/cli.py | 2 +- 17 sqlparse/__main__.py | 2 +-
17 3 files changed, 3 insertions(+), 3 deletions(-) 18 sqlparse/cli.py | 2 +-
19 4 files changed, 54 insertions(+), 3 deletions(-)
20 create mode 100644 0001-sqlparse-change-shebang-to-python3.patch
18 21
22diff --git a/0001-sqlparse-change-shebang-to-python3.patch b/0001-sqlparse-change-shebang-to-python3.patch
23new file mode 100644
24index 0000000..ad6c50f
25--- /dev/null
26+++ b/0001-sqlparse-change-shebang-to-python3.patch
27@@ -0,0 +1,51 @@
28+From 10c9d3341d64d697f678a64ae707f6bda21565bb Mon Sep 17 00:00:00 2001
29+From: Changqing Li <changqing.li@windriver.com>
30+Date: Mon, 9 Mar 2020 13:10:37 +0800
31+Subject: [PATCH] sqlparse: change shebang to python3
32+
33+Upstream-Status: Pending
34+
35+Don't send upstream since upstream still support python2,
36+we can only make this change after python2 is offcially
37+dropped.
38+
39+Signed-off-by: Changqing Li <changqing.li@windriver.com>
40+---
41+ setup.py | 2 +-
42+ sqlparse/__main__.py | 2 +-
43+ sqlparse/cli.py | 2 +-
44+ 3 files changed, 3 insertions(+), 3 deletions(-)
45+
46+diff --git a/setup.py b/setup.py
47+index 345d0ce..ce3abc3 100644
48+--- a/setup.py
49++++ b/setup.py
50+@@ -1,4 +1,4 @@
51+-#!/usr/bin/env python
52++#!/usr/bin/env python3
53+ # -*- coding: utf-8 -*-
54+ #
55+ # Copyright (C) 2009-2018 the sqlparse authors and contributors
56+diff --git a/sqlparse/__main__.py b/sqlparse/__main__.py
57+index 867d75d..dd0c074 100644
58+--- a/sqlparse/__main__.py
59++++ b/sqlparse/__main__.py
60+@@ -1,4 +1,4 @@
61+-#!/usr/bin/env python
62++#!/usr/bin/env python3
63+ # -*- coding: utf-8 -*-
64+ #
65+ # Copyright (C) 2009-2018 the sqlparse authors and contributors
66+diff --git a/sqlparse/cli.py b/sqlparse/cli.py
67+index 25555a5..8bf050a 100755
68+--- a/sqlparse/cli.py
69++++ b/sqlparse/cli.py
70+@@ -1,4 +1,4 @@
71+-#!/usr/bin/env python
72++#!/usr/bin/env python3
73+ # -*- coding: utf-8 -*-
74+ #
75+ # Copyright (C) 2009-2018 the sqlparse authors and contributors
76+--
77+2.7.4
78+
19diff --git a/setup.py b/setup.py 79diff --git a/setup.py b/setup.py
20index 345d0ce..ce3abc3 100644 80index ede0aff..dc6a323 100644
21--- a/setup.py 81--- a/setup.py
22+++ b/setup.py 82+++ b/setup.py
23@@ -1,4 +1,4 @@ 83@@ -1,4 +1,4 @@
24-#!/usr/bin/env python 84-#!/usr/bin/env python
25+#!/usr/bin/env python3 85+#!/usr/bin/env python3
26 # -*- coding: utf-8 -*-
27 # 86 #
28 # Copyright (C) 2009-2018 the sqlparse authors and contributors 87 # Copyright (C) 2009-2020 the sqlparse authors and contributors
88 # <see AUTHORS file>
29diff --git a/sqlparse/__main__.py b/sqlparse/__main__.py 89diff --git a/sqlparse/__main__.py b/sqlparse/__main__.py
30index 867d75d..dd0c074 100644 90index 2bf2513..6a3a115 100644
31--- a/sqlparse/__main__.py 91--- a/sqlparse/__main__.py
32+++ b/sqlparse/__main__.py 92+++ b/sqlparse/__main__.py
33@@ -1,4 +1,4 @@ 93@@ -1,4 +1,4 @@
34-#!/usr/bin/env python 94-#!/usr/bin/env python
35+#!/usr/bin/env python3 95+#!/usr/bin/env python3
36 # -*- coding: utf-8 -*-
37 # 96 #
38 # Copyright (C) 2009-2018 the sqlparse authors and contributors 97 # Copyright (C) 2009-2020 the sqlparse authors and contributors
98 # <see AUTHORS file>
39diff --git a/sqlparse/cli.py b/sqlparse/cli.py 99diff --git a/sqlparse/cli.py b/sqlparse/cli.py
40index 25555a5..8bf050a 100755 100index 7a8aacb..9c727e8 100755
41--- a/sqlparse/cli.py 101--- a/sqlparse/cli.py
42+++ b/sqlparse/cli.py 102+++ b/sqlparse/cli.py
43@@ -1,4 +1,4 @@ 103@@ -1,4 +1,4 @@
44-#!/usr/bin/env python 104-#!/usr/bin/env python
45+#!/usr/bin/env python3 105+#!/usr/bin/env python3
46 # -*- coding: utf-8 -*-
47 # 106 #
48 # Copyright (C) 2009-2018 the sqlparse authors and contributors 107 # Copyright (C) 2009-2020 the sqlparse authors and contributors
108 # <see AUTHORS file>
49-- 109--
502.7.4 1102.17.1
51 111