summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb
new file mode 100644
index 0000000000..e4ac403eb5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
8 file://run-ptest \
9 "
10
11SRC_URI[sha256sum] = "d446183e84b8349fa3061f0fe7f06ca94ba65b426946ffebe6e3e8295332420c"
12
13export BUILD_SYS
14export HOST_SYS
15
16inherit pypi ptest python_flit_core
17
18RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20 ${PYTHON_PN}-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"