summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb
new file mode 100644
index 0000000000..6944ecb979
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[sha256sum] = "5b2b8882ec8a3c3733cce6965cc098b6d80b417f21229ab90b18fe551d619f90"
11
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
14RDEPENDS_${PN} = "\
15 ${PYTHON_PN}-meld3 \
16"
17
18SRC_URI += "file://supervisord.conf \
19 file://supervisor.service \
20 "
21SYSTEMD_SERVICE_${PN} = "supervisor.service"
22
23do_install_append() {
24 install -d ${D}${sysconfdir}/supervisor
25 install -d ${D}${systemd_system_unitdir}
26
27 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
28 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
29}