summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tornado_6.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_6.4.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.4.bb b/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
new file mode 100644
index 0000000000..e3d0209e1a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9SRC_URI[sha256sum] = "72291fa6e6bc84e626589f1c29d90a5a6d593ef5ae68052ee2ef000dfd273dee"
10
11inherit pypi setuptools3
12
13# Requires _compression which is currently located in misc
14RDEPENDS:${PN} += " \
15 python3-asyncio \
16 python3-certifi \
17 python3-compression \
18 python3-ctypes \
19 python3-email \
20 python3-html \
21 python3-json \
22 python3-misc \
23 python3-multiprocessing \
24 python3-numbers \
25 python3-pkgutil \
26 python3-pycurl \
27 python3-threading \
28 python3-unittest \
29"
30
31RDEPENDS:${PN}-test += "python3-unittest"
32
33PACKAGES =+ "\
34 ${PN}-test \
35"
36
37FILES:${PN}-test = " \
38 ${libdir}/${PYTHON_DIR}/site-packages/*/test \
39"