summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb b/meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb
new file mode 100644
index 0000000000..6720f50dae
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-virtualenv_20.26.3.bb
@@ -0,0 +1,22 @@
1# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "A tool for creating isolated virtual python environments."
5HOMEPAGE = "https://github.com/pypa/virtualenv"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
8
9SRC_URI[sha256sum] = "4c43a2a236279d9ea36a0d76f98d84bd6ca94ac4e0f4a3b9d46d05e10fea542a"
10
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15 python3-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += " \
19 python3-distlib \
20 python3-filelock \
21 python3-platformdirs \
22"