summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb b/meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb
new file mode 100644
index 0000000000..e40561e8fa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-virtualenv_20.26.6.bb
@@ -0,0 +1,26 @@
1# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "A tool for creating isolated virtual python environments."
5HOMEPAGE = "https://github.com/pypa/virtualenv"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
8
9SRC_URI[sha256sum] = "280aede09a2a5c317e409a00102e7077c6432c5a38f0ef938e643805a7ad2c48"
10
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15 python3-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += " \
19 python3-compression \
20 python3-distlib \
21 python3-filelock \
22 python3-json \
23 python3-misc \
24 python3-modules \
25 python3-platformdirs \
26"