summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-web3_6.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-web3_6.12.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_6.12.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.12.0.bb b/meta-python/recipes-devtools/python/python3-web3_6.12.0.bb
new file mode 100644
index 0000000000..f0f126508a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_6.12.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
6
7SRC_URI[sha256sum] = "81a68519ff4416eee7f16d4dbc498e70deb90908c7c1d7bebc950e5f3d1f29d5"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-distutils \
14 python3-eth-account \
15 python3-idna \
16 python3-jsonschema \
17 python3-google-api-core \
18 python3-lru-dict \
19 python3-requests \
20 python3-setuptools \
21 python3-websockets \
22"