summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-web3_6.15.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_6.15.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb b/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
new file mode 100644
index 0000000000..e216857dec
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
6
7SRC_URI[sha256sum] = "a646d1fe5eba00625b5459d23910e472f0d0aa063788422bff2648ca4e1ebc7e"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-eth-account \
14 python3-idna \
15 python3-jsonschema \
16 python3-google-api-core \
17 python3-lru-dict \
18 python3-requests \
19 python3-setuptools \
20 python3-websockets \
21"