summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-web3_7.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-web3_7.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_7.9.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_7.9.0.bb b/meta-python/recipes-devtools/python/python3-web3_7.9.0.bb
new file mode 100644
index 0000000000..3b740329f4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_7.9.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1d34d9701a1461e4bd71a904ac4cf7be"
6
7SRC_URI[sha256sum] = "3c4487a7ac57e0a187bd7ee03db455d94f354d15cca45f097f15f7281ad1a01f"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-eth-abi \
14 python3-eth-account \
15 python3-eth-hash \
16 python3-eth-typing \
17 python3-eth-utils \
18 python3-hexbytes \
19 python3-jsonschema \
20 python3-protobuf \
21 python3-pydantic \
22 python3-requests \
23 python3-typing-extensions \
24 python3-websockets \
25 python3-pyunormalize \
26"