summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websockets_10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websockets_10.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websockets_10.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websockets_10.1.bb b/meta-python/recipes-devtools/python/python3-websockets_10.1.bb
new file mode 100644
index 0000000000..6dd29a9ff6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websockets_10.1.bb
@@ -0,0 +1,15 @@
1SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
2HOMEPAGE = "https://github.com/aaugustin/websockets"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=78c2cc91e172ca96d6f8e4a76c739ec6"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "181d2b25de5a437b36aefedaf006ecb6fa3aa1328ec0236cdde15f32f9d3ff6d"
10
11BBCLASSEXTEND = "native nativesdk"
12
13RDEPENDS:${PN} = "\
14 ${PYTHON_PN}-asyncio \
15"