summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb b/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
new file mode 100644
index 0000000000..04f25532a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Python 2 and 3 compatibility library"
2HOMEPAGE = "https://xlsxwriter.readthedocs.io"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e5c795ec8cf90514a6d844b1d3cc3224"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "XlsxWriter"
10
11RDEPENDS:${PN} += " \
12 python3-crypt \
13 python3-datetime \
14 python3-compression \
15 python3-numbers \
16 python3-io \
17"
18
19SRC_URI[sha256sum] = "53005f03e8eb58f061ebf41d5767c7495ee0772c2396fe26b7e0ca22fa9c2570"
20
21BBCLASSEXTEND = "native nativesdk"