summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb b/meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb
new file mode 100644
index 0000000000..3f9c06365f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmlschema_1.5.3.bb
@@ -0,0 +1,19 @@
1SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
2HOMEPAGE = "https://github.com/sissaschool/xmlschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=47489cb18c469474afeb259ed1d4832f"
5
6SRC_URI[sha256sum] = "a7db4c8ae2afa28654d15fcbf5d7f22f0441b5611e50426426e5418f369b5c79"
7
8PYPI_PACKAGE = "xmlschema"
9inherit pypi setuptools3
10
11DEPENDS += "\
12 ${PYTHON_PN}-elementpath-native \
13"
14
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-elementpath \
17"
18
19BBCLASSEXTEND = "native nativesdk"