summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb b/meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb
new file mode 100644
index 0000000000..9be7cb5551
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmlschema_2.3.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
2HOMEPAGE = "https://github.com/sissaschool/xmlschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0ab20f8e337bea2e6874f372edfd12c0"
5
6SRC_URI[sha256sum] = "2eb426c5710833a05610c22c8766713a1b87e9405e3eca0b7c658375bf7ec810"
7
8PYPI_PACKAGE = "xmlschema"
9inherit pypi setuptools3
10
11DEPENDS += "\
12 ${PYTHON_PN}-elementpath-native \
13"
14
15RDEPENDS:${PN} += "\
16 ${PYTHON_PN}-elementpath \
17 ${PYTHON_PN}-modules \
18"
19
20BBCLASSEXTEND = "native nativesdk"