diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yappi')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch | 24 |
2 files changed, 26 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch index fa58897e68..274f6f527b 100644 --- a/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch +++ b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch | |||
@@ -8,10 +8,9 @@ Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> | |||
8 | tests/test_asyncio.py | 2 +- | 8 | tests/test_asyncio.py | 2 +- |
9 | tests/test_asyncio_context_vars.py | 2 +- | 9 | tests/test_asyncio_context_vars.py | 2 +- |
10 | tests/test_functionality.py | 2 +- | 10 | tests/test_functionality.py | 2 +- |
11 | tests/test_gevent.py | 2 +- | ||
12 | tests/test_hooks.py | 2 +- | 11 | tests/test_hooks.py | 2 +- |
13 | tests/test_tags.py | 2 +- | 12 | tests/test_tags.py | 2 +- |
14 | 6 files changed, 6 insertions(+), 6 deletions(-) | 13 | 5 files changed, 6 insertions(+), 6 deletions(-) |
15 | 14 | ||
16 | --- a/tests/test_asyncio.py | 15 | --- a/tests/test_asyncio.py |
17 | +++ b/tests/test_asyncio.py | 16 | +++ b/tests/test_asyncio.py |
@@ -23,7 +22,7 @@ Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> | |||
23 | +from .utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io | 22 | +from .utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io |
24 | 23 | ||
25 | 24 | ||
26 | @asyncio.coroutine | 25 | async def async_sleep(sec): |
27 | --- a/tests/test_asyncio_context_vars.py | 26 | --- a/tests/test_asyncio_context_vars.py |
28 | +++ b/tests/test_asyncio_context_vars.py | 27 | +++ b/tests/test_asyncio_context_vars.py |
29 | @@ -5,7 +5,7 @@ import contextvars | 28 | @@ -5,7 +5,7 @@ import contextvars |
@@ -3870,17 +3869,6 @@ Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> | |||
3870 | + # import sys;sys.argv = ['', 'BasicUsage.test_run_as_script'] | 3869 | + # import sys;sys.argv = ['', 'BasicUsage.test_run_as_script'] |
3871 | + # import sys;sys.argv = ['', 'MultithreadedScenarios.test_subsequent_profile'] | 3870 | + # import sys;sys.argv = ['', 'MultithreadedScenarios.test_subsequent_profile'] |
3872 | + unittest.main() | 3871 | + unittest.main() |
3873 | --- a/tests/test_gevent.py | ||
3874 | +++ b/tests/test_gevent.py | ||
3875 | @@ -4,7 +4,7 @@ import yappi | ||
3876 | import gevent | ||
3877 | from gevent.event import Event | ||
3878 | import threading | ||
3879 | -from utils import ( | ||
3880 | +from .utils import ( | ||
3881 | YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io, | ||
3882 | burn_io_gevent | ||
3883 | ) | ||
3884 | --- a/tests/test_hooks.py | 3872 | --- a/tests/test_hooks.py |
3885 | +++ b/tests/test_hooks.py | 3873 | +++ b/tests/test_hooks.py |
3886 | @@ -5,7 +5,7 @@ import unittest | 3874 | @@ -5,7 +5,7 @@ import unittest |
diff --git a/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch b/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch new file mode 100644 index 0000000000..a9bf612db8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From 38afdacf526410f970afc58e147c7377c6c7112c Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?S=C3=BCmer=20Cip?= <sumer.cip@platform.sh> | ||
3 | Date: Fri, 25 Nov 2022 15:58:03 +0300 | ||
4 | Subject: [PATCH 2/2] add 3.11 to the setup | ||
5 | |||
6 | --- | ||
7 | setup.py | 1 + | ||
8 | 1 file changed, 1 insertion(+) | ||
9 | |||
10 | diff --git a/setup.py b/setup.py | ||
11 | index d006787..96e2a66 100644 | ||
12 | --- a/setup.py | ||
13 | +++ b/setup.py | ||
14 | @@ -56,6 +56,7 @@ CLASSIFIERS = [ | ||
15 | 'Programming Language :: Python :: 3.8', | ||
16 | 'Programming Language :: Python :: 3.9', | ||
17 | 'Programming Language :: Python :: 3.10', | ||
18 | + 'Programming Language :: Python :: 3.11', | ||
19 | 'Programming Language :: Python :: Implementation :: CPython', | ||
20 | 'Operating System :: OS Independent', | ||
21 | 'Topic :: Software Development :: Libraries', | ||
22 | -- | ||
23 | 2.30.2 | ||
24 | |||