diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb b/meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb new file mode 100644 index 0000000000..45a5f058ac --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Yet Another Python Profiler" | ||
2 | HOMEPAGE = "https://github.com/sumerc/yappi" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee" | ||
6 | |||
7 | SRC_URI[sha256sum] = "855890cd9a90d833dd2df632d648de8ccd0a4c3131f1edc8abd004db0625b5e8" | ||
8 | |||
9 | SRC_URI += " \ | ||
10 | file://run-ptest \ | ||
11 | file://0001-Fix-imports-for-ptests.patch \ | ||
12 | " | ||
13 | |||
14 | inherit pypi setuptools3 ptest | ||
15 | |||
16 | RDEPENDS:${PN} += "\ | ||
17 | ${PYTHON_PN}-datetime \ | ||
18 | ${PYTHON_PN}-pickle \ | ||
19 | ${PYTHON_PN}-threading \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS:${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-gevent \ | ||
24 | ${PYTHON_PN}-multiprocessing \ | ||
25 | ${PYTHON_PN}-pytest \ | ||
26 | ${PYTHON_PN}-profile \ | ||
27 | ${PYTHON_PN}-zopeinterface \ | ||
28 | " | ||
29 | |||
30 | do_install_ptest() { | ||
31 | install -d ${D}${PTEST_PATH}/tests | ||
32 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
33 | cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/ | ||
34 | } | ||