summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb b/meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb
new file mode 100644
index 0000000000..305e42a619
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-zopeinterface_5.4.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Interface definitions for Zope products"
2LICENSE = "ZPL-2.1"
3LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
4
5PYPI_PACKAGE = "zope.interface"
6
7inherit pypi setuptools3
8SRC_URI[sha256sum] = "5dba5f530fec3f0988d83b78cc591b58c0b6eb8431a85edd1569a0539a8a5a0e"
9
10PACKAGES =. "${PN}-test "
11
12RPROVIDES_${PN} += "zope-interfaces"
13
14RDEPENDS_${PN}_class-target += "${PYTHON_PN}-datetime"
15RDEPENDS_${PN}-test += "python3-unittest python3-doctest"
16
17FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
18FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
19FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
20FILES_${PN}-test += " \
21 ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
22 ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
23"