summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_3.4.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow-heif/0001-setup.py-support-cross-compiling.patch56
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow-heif_0.22.0.bb20
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-79.0-65.6-to-65.6.patch42
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-80.0-65.6-to-65.6.patch42
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast_14.0.7.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-89.patch (renamed from meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch)8
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzstd_0.17.0.bb2
8 files changed, 96 insertions, 83 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_3.4.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_3.4.1.bb
index 01030b43f7..36babb5d0b 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_3.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_3.4.1.bb
@@ -6,6 +6,6 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6abe80c028e4ee5304
6 6
7SRC_URI[sha256sum] = "e5fa88732bbcfb5437ee554e18f842a8f6c86be73656b0580ee146fd373176c9" 7SRC_URI[sha256sum] = "e5fa88732bbcfb5437ee554e18f842a8f6c86be73656b0580ee146fd373176c9"
8 8
9inherit setuptools3 pypi 9inherit python_setuptools_build_meta pypi
10 10
11BBCLASSEXTEND = "native nativesdk" 11BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pillow-heif/0001-setup.py-support-cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pillow-heif/0001-setup.py-support-cross-compiling.patch
deleted file mode 100644
index 66cf7a9244..0000000000
--- a/meta-python/recipes-devtools/python/python3-pillow-heif/0001-setup.py-support-cross-compiling.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1From 98e6831754712221ce030ce8b27e100a3926c543 Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Mon, 5 May 2025 16:08:37 +0000
4Subject: [PATCH] setup.py: support cross compiling
5
6Upstream-Status: Inappropriate [oe specific]
7
8Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
9---
10 setup.py | 19 +++++++++++--------
11 1 file changed, 11 insertions(+), 8 deletions(-)
12
13diff --git a/setup.py b/setup.py
14index 68945e4..67566e8 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -125,12 +125,12 @@ class PillowHeifBuildExt(build_ext):
18 self._add_directory(library_dirs, match.group(1))
19
20 # include, rpath, if set as environment variables
21- for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE"):
22+ for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE", "STAGING_INCDIR"):
23 if k in os.environ:
24 for d in os.environ[k].split(os.path.pathsep):
25 self._add_directory(include_dirs, d)
26
27- for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB"):
28+ for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB", "STAGING_LIBDIR"):
29 if k in os.environ:
30 for d in os.environ[k].split(os.path.pathsep):
31 self._add_directory(library_dirs, d)
32@@ -199,12 +199,15 @@ class PillowHeifBuildExt(build_ext):
33 self._update_extension("_pillow_heif", ["heif"], extra_compile_args=["-O3", "-Werror"])
34 else: # let's assume it's some kind of linux
35 # this old code waiting for refactoring, when time comes.
36- self._add_directory(include_dirs, "/usr/local/include")
37- self._add_directory(include_dirs, "/usr/include")
38- self._add_directory(library_dirs, "/usr/local/lib")
39- self._add_directory(library_dirs, "/usr/lib64")
40- self._add_directory(library_dirs, "/usr/lib")
41- self._add_directory(library_dirs, "/lib")
42+ include_os_path = os.environ.get("STAGING_INCDIR")
43+ if include_os_path:
44+ for path in include_os_path.split(os.pathsep):
45+ self._add_directory(include_dirs, path)
46+
47+ lib_os_path = os.environ.get("STAGING_LIBDIR")
48+ if lib_os_path:
49+ for path in lib_os_path.split(os.pathsep):
50+ self._add_directory(library_dirs, path)
51
52 self._update_extension("_pillow_heif", ["heif"], extra_compile_args=["-O3", "-Werror"])
53
54--
552.39.5
56
diff --git a/meta-python/recipes-devtools/python/python3-pillow-heif_0.22.0.bb b/meta-python/recipes-devtools/python/python3-pillow-heif_0.22.0.bb
deleted file mode 100644
index 7f5dfac702..0000000000
--- a/meta-python/recipes-devtools/python/python3-pillow-heif_0.22.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "Python interface for libheif library"
2HOMEPAGE = "https://github.com/bigcat88/pillow_heif"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b6c07a92aed67c33bc346748d7c7e991"
5
6# While this item does not require it, it depends on libheif which does
7LICENSE_FLAGS = "commercial"
8
9PYPI_PACKAGE = "pillow_heif"
10
11inherit pypi python_setuptools_build_meta
12
13SRC_URI += "file://0001-setup.py-support-cross-compiling.patch"
14SRC_URI[sha256sum] = "61d473929340d3073722f6316b7fbbdb11132faa6bac0242328e8436cc55b39a"
15
16DEPENDS += "libheif"
17
18RDEPENDS:${PN} += "python3-pillow"
19
20BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-79.0-65.6-to-65.6.patch b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-79.0-65.6-to-65.6.patch
new file mode 100644
index 0000000000..b0d4a88c8e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-79.0-65.6-to-65.6.patch
@@ -0,0 +1,42 @@
1From ef27075e087e139921b99729a4ec7683e42c5c4a Mon Sep 17 00:00:00 2001
2From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com>
3Date: Mon, 21 Apr 2025 16:34:55 +0200
4Subject: [PATCH] Update setuptools requirement from <79.0,>=65.6 to
5 >=65.6,<80.0 (#1056)
6
7Upstream-Status: Backport [https://github.com/home-assistant-libs/pychromecast/commit/ef27075e087e139921b99729a4ec7683e42c5c4a]
8
9Updates the requirements on [setuptools](https://github.com/pypa/setuptools) to permit the latest version.
10- [Release notes](https://github.com/pypa/setuptools/releases)
11- [Changelog](https://github.com/pypa/setuptools/blob/main/NEWS.rst)
12- [Commits](https://github.com/pypa/setuptools/compare/v65.6.0...v79.0.0)
13
14---
15updated-dependencies:
16- dependency-name: setuptools
17 dependency-version: 79.0.0
18 dependency-type: direct:production
19...
20
21Signed-off-by: dependabot[bot] <support@github.com>
22Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
23
24Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
25---
26 pyproject.toml | 2 +-
27 1 file changed, 1 insertion(+), 1 deletion(-)
28
29diff --git a/pyproject.toml b/pyproject.toml
30index 34f5dc0..88d67fe 100644
31--- a/pyproject.toml
32+++ b/pyproject.toml
33@@ -1,5 +1,5 @@
34 [build-system]
35-requires = ["setuptools>=65.6,<79.0", "wheel>=0.37.1,<0.46.0"]
36+requires = ["setuptools>=65.6,<80.0", "wheel>=0.37.1,<0.46.0"]
37 build-backend = "setuptools.build_meta"
38
39 [project]
40--
412.39.5
42
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-80.0-65.6-to-65.6.patch b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-80.0-65.6-to-65.6.patch
new file mode 100644
index 0000000000..8630c1632d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pychromecast/0001-Update-setuptools-requirement-from-80.0-65.6-to-65.6.patch
@@ -0,0 +1,42 @@
1From 7017a1db10a21ed97b79800e31a2f7c70abbffc3 Mon Sep 17 00:00:00 2001
2From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com>
3Date: Mon, 28 Apr 2025 16:43:13 +0200
4Subject: [PATCH] Update setuptools requirement from <80.0,>=65.6 to
5 >=65.6,<81.0 (#1060)
6
7Upstream-Status: Backport [https://github.com/home-assistant-libs/pychromecast/commit/7017a1db10a21ed97b79800e31a2f7c70abbffc3]
8
9Updates the requirements on [setuptools](https://github.com/pypa/setuptools) to permit the latest version.
10- [Release notes](https://github.com/pypa/setuptools/releases)
11- [Changelog](https://github.com/pypa/setuptools/blob/main/NEWS.rst)
12- [Commits](https://github.com/pypa/setuptools/compare/v65.6.0...v80.0.0)
13
14---
15updated-dependencies:
16- dependency-name: setuptools
17 dependency-version: 80.0.0
18 dependency-type: direct:production
19...
20
21Signed-off-by: dependabot[bot] <support@github.com>
22Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
23
24Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
25---
26 pyproject.toml | 2 +-
27 1 file changed, 1 insertion(+), 1 deletion(-)
28
29diff --git a/pyproject.toml b/pyproject.toml
30index 88d67fe..d5a518c 100644
31--- a/pyproject.toml
32+++ b/pyproject.toml
33@@ -1,5 +1,5 @@
34 [build-system]
35-requires = ["setuptools>=65.6,<80.0", "wheel>=0.37.1,<0.46.0"]
36+requires = ["setuptools>=65.6,<81.0", "wheel>=0.37.1,<0.46.0"]
37 build-backend = "setuptools.build_meta"
38
39 [project]
40--
412.39.5
42
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_14.0.7.bb b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.7.bb
index 7bae0721db..260f6395b7 100644
--- a/meta-python/recipes-devtools/python/python3-pychromecast_14.0.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.7.bb
@@ -3,7 +3,12 @@ HOMEPAGE = "https://github.com/balloob/pychromecast"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
5 5
6SRC_URI += "file://0001-Update-setuptools-requirement-from-78.0-65.6-to-65.6.patch" 6SRC_URI += "\
7 file://0001-Update-setuptools-requirement-from-78.0-65.6-to-65.6.patch \
8 file://0001-Update-setuptools-requirement-from-79.0-65.6-to-65.6.patch \
9 file://0001-Update-setuptools-requirement-from-80.0-65.6-to-65.6.patch \
10"
11
7SRC_URI[sha256sum] = "7abbae80a2c9e05b93b1a7b8b4d771bbc764d88fd5e56a566f46ac1bd3f93848" 12SRC_URI[sha256sum] = "7abbae80a2c9e05b93b1a7b8b4d771bbc764d88fd5e56a566f46ac1bd3f93848"
8 13
9inherit pypi python_setuptools_build_meta 14inherit pypi python_setuptools_build_meta
diff --git a/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch b/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-89.patch
index 8fc26bd90b..f7b43b12a7 100644
--- a/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch
+++ b/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-89.patch
@@ -1,7 +1,7 @@
1From e648bb2439cad0d2ce47875edc7944d0b446fdb4 Mon Sep 17 00:00:00 2001 1From bc9b975c9f41e43481a2eb0623b4180926baecec Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 9 Apr 2025 14:38:31 -0700 3Date: Wed, 9 Apr 2025 14:38:31 -0700
4Subject: [PATCH] Bump setuptools dependency from 74 to 79 4Subject: [PATCH] Bump setuptools dependency from 74 to 89
5 5
6Upstream sticks to 0.74 since setuptools have dropped msvc9compiler 6Upstream sticks to 0.74 since setuptools have dropped msvc9compiler
7support beyond that which is needed for python 3.9 on windows. We 7support beyond that which is needed for python 3.9 on windows. We
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
14 1 file changed, 1 insertion(+), 1 deletion(-) 14 1 file changed, 1 insertion(+), 1 deletion(-)
15 15
16diff --git a/pyproject.toml b/pyproject.toml 16diff --git a/pyproject.toml b/pyproject.toml
17index dd885e4..9f273b3 100644 17index dd885e4..5d4d511 100644
18--- a/pyproject.toml 18--- a/pyproject.toml
19+++ b/pyproject.toml 19+++ b/pyproject.toml
20@@ -1,6 +1,6 @@ 20@@ -1,6 +1,6 @@
@@ -22,6 +22,6 @@ index dd885e4..9f273b3 100644
22 # setuptools 64+ support --build-option 22 # setuptools 64+ support --build-option
23 # setuptools 74+ drops distutils.msvc9compiler required for Python 3.9 under Windows 23 # setuptools 74+ drops distutils.msvc9compiler required for Python 3.9 under Windows
24-requires = ["setuptools>=64,<74"] 24-requires = ["setuptools>=64,<74"]
25+requires = ["setuptools>=64,<79"] 25+requires = ["setuptools>=64,<89"]
26 backend-path = ["build_script"] 26 backend-path = ["build_script"]
27 build-backend = "pyzstd_pep517" 27 build-backend = "pyzstd_pep517"
diff --git a/meta-python/recipes-devtools/python/python3-pyzstd_0.17.0.bb b/meta-python/recipes-devtools/python/python3-pyzstd_0.17.0.bb
index d842a92caf..d93411beba 100644
--- a/meta-python/recipes-devtools/python/python3-pyzstd_0.17.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzstd_0.17.0.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=aedb5a2679cd1552fb61c181ef974b9e"
8 8
9PYPI_PACKAGE = "pyzstd" 9PYPI_PACKAGE = "pyzstd"
10 10
11SRC_URI += "file://0001-Bump-setuptools-dependency-from-74-to-79.patch" 11SRC_URI += "file://0001-Bump-setuptools-dependency-from-74-to-89.patch"
12SRC_URI[sha256sum] = "d84271f8baa66c419204c1dd115a4dec8b266f8a2921da21b81764fa208c1db6" 12SRC_URI[sha256sum] = "d84271f8baa66c419204c1dd115a4dec8b266f8a2921da21b81764fa208c1db6"
13 13
14inherit pypi python_setuptools_build_meta ptest-python-pytest 14inherit pypi python_setuptools_build_meta ptest-python-pytest