summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
deleted file mode 100644
index 2b8abb8b80..0000000000
--- a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1SUMMARY = "Wraps the best available JSON implementation available in a common interface"
2DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
3provides a uniform API regardless of which JSON implementation is used."
4HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://0001-setup.py-Do-not-use-2to3.patch \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-nose \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
26SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
27
28RDEPENDS:${PN} += "${PYTHON_PN}-simplejson"