diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pylint.inc | 38 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb | 40 |
2 files changed, 38 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc deleted file mode 100644 index ba85b98878..0000000000 --- a/meta-python/recipes-devtools/python/python-pylint.inc +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | ||
2 | HOMEPAGE= "http://www.pylint.org/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | |||
6 | SRC_URI[md5sum] = "2eb5f3cb8fe567eaf5420dd415012202" | ||
7 | SRC_URI[sha256sum] = "c77311859e0c2d7932095f30d2b1bfdc4b6fe111f534450ba727a52eae330ef2" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
12 | |||
13 | do_install_append(){ | ||
14 | rm ${D}${bindir}/pylint | ||
15 | cat >> ${D}${bindir}/pylint <<EOF | ||
16 | #!/usr/bin/env ${PYTHON_PN} | ||
17 | from pylint import run_pylint | ||
18 | run_pylint() | ||
19 | EOF | ||
20 | chmod 755 ${D}${bindir}/pylint | ||
21 | sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript | ||
22 | } | ||
23 | |||
24 | PACKAGES =+ "${PN}-tests" | ||
25 | FILES_${PN}-tests+= " \ | ||
26 | ${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \ | ||
27 | ${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \ | ||
28 | " | ||
29 | |||
30 | RDEPENDS_${PN} += "${PYTHON_PN}-astroid \ | ||
31 | ${PYTHON_PN}-isort \ | ||
32 | ${PYTHON_PN}-numbers \ | ||
33 | ${PYTHON_PN}-shell \ | ||
34 | ${PYTHON_PN}-json \ | ||
35 | ${PYTHON_PN}-pkgutil \ | ||
36 | ${PYTHON_PN}-difflib \ | ||
37 | ${PYTHON_PN}-netserver \ | ||
38 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb index 563e8316cf..7a873a1e12 100644 --- a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb +++ b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb | |||
@@ -1,2 +1,38 @@ | |||
1 | inherit setuptools3 python3-dir | 1 | SUMMARY="Pylint is a Python source code analyzer" |
2 | require python-pylint.inc | 2 | HOMEPAGE= "http://www.pylint.org/" |
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | |||
6 | SRC_URI[md5sum] = "2eb5f3cb8fe567eaf5420dd415012202" | ||
7 | SRC_URI[sha256sum] = "c77311859e0c2d7932095f30d2b1bfdc4b6fe111f534450ba727a52eae330ef2" | ||
8 | |||
9 | inherit pypi setuptools3 python3-dir | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
12 | |||
13 | do_install_append(){ | ||
14 | rm ${D}${bindir}/pylint | ||
15 | cat >> ${D}${bindir}/pylint <<EOF | ||
16 | #!/usr/bin/env ${PYTHON_PN} | ||
17 | from pylint import run_pylint | ||
18 | run_pylint() | ||
19 | EOF | ||
20 | chmod 755 ${D}${bindir}/pylint | ||
21 | sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript | ||
22 | } | ||
23 | |||
24 | PACKAGES =+ "${PN}-tests" | ||
25 | FILES_${PN}-tests+= " \ | ||
26 | ${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \ | ||
27 | ${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \ | ||
28 | " | ||
29 | |||
30 | RDEPENDS_${PN} += "${PYTHON_PN}-astroid \ | ||
31 | ${PYTHON_PN}-isort \ | ||
32 | ${PYTHON_PN}-numbers \ | ||
33 | ${PYTHON_PN}-shell \ | ||
34 | ${PYTHON_PN}-json \ | ||
35 | ${PYTHON_PN}-pkgutil \ | ||
36 | ${PYTHON_PN}-difflib \ | ||
37 | ${PYTHON_PN}-netserver \ | ||
38 | " | ||