summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-astor/0001-rtrip.py-convert-to-python3.patch36
-rw-r--r--meta-python/recipes-devtools/python/python3-astor_0.8.1.bb4
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astor/0001-rtrip.py-convert-to-python3.patch b/meta-python/recipes-devtools/python/python3-astor/0001-rtrip.py-convert-to-python3.patch
new file mode 100644
index 0000000000..009951864a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astor/0001-rtrip.py-convert-to-python3.patch
@@ -0,0 +1,36 @@
1From 1a477968593a14ee9c8597c1ed4e8b61a7731e15 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Wed, 23 Dec 2020 02:23:13 +0000
4Subject: [PATCH] rtrip.py: convert to python3
5
6As Python 2 reached end of life (EOL), so convert rtrip.py to python3.
7
8Upstream-Status: Submitted [https://github.com/berkerpeksag/astor/pull/192]
9
10Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
11---
12 astor/rtrip.py | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/astor/rtrip.py b/astor/rtrip.py
16index 8b108e7..e2e30a6 100755
17--- a/astor/rtrip.py
18+++ b/astor/rtrip.py
19@@ -1,4 +1,4 @@
20-#! /usr/bin/env python
21+#! /usr/bin/env python3
22 # -*- coding: utf-8 -*-
23 """
24 Part of the astor library for Python AST manipulation.
25@@ -160,7 +160,7 @@ def usage(msg):
26
27 Usage:
28
29- python -m astor.rtrip [readonly] [<source>]
30+ python3 -m astor.rtrip [readonly] [<source>]
31
32
33 This utility tests round-tripping of Python source to AST
34--
352.26.2
36
diff --git a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
index 125a0236ec..5048e5bec9 100644
--- a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
@@ -4,7 +4,9 @@ SECTION = "devel/python"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=561205fdabc3ec52cae2d30815b8ade7" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=561205fdabc3ec52cae2d30815b8ade7"
6 6
7SRC_URI = "git://github.com/berkerpeksag/astor.git " 7SRC_URI = "git://github.com/berkerpeksag/astor.git \
8 file://0001-rtrip.py-convert-to-python3.patch \
9"
8SRCREV ?= "c7553c79f9222e20783fe9bd8a553f932e918072" 10SRCREV ?= "c7553c79f9222e20783fe9bd8a553f932e918072"
9 11
10inherit setuptools3 12inherit setuptools3