diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-portion/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-portion_2.5.0.bb | 22 |
2 files changed, 22 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-portion/run-ptest b/meta-python/recipes-devtools/python/python3-portion/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-portion/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb b/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb index f4e5d2036e..269473e933 100644 --- a/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb +++ b/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb | |||
@@ -5,12 +5,28 @@ SECTION = "devel/python" | |||
5 | LICENSE = "LGPL-3.0-only" | 5 | LICENSE = "LGPL-3.0-only" |
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404" | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta | 8 | inherit pypi python_setuptools_build_meta ptest |
9 | 9 | ||
10 | SRC_URI[sha256sum] = "80ae7bab71f4844e3eb33c57954d76a3bd4cb351039b6e260e779325aeb4a487" | 10 | SRC_URI[sha256sum] = "80ae7bab71f4844e3eb33c57954d76a3bd4cb351039b6e260e779325aeb4a487" |
11 | 11 | ||
12 | RDEPENDS:${PN} = "\ | 12 | SRC_URI += " \ |
13 | python3-sortedcontainers \ | 13 | file://run-ptest \ |
14 | " | 14 | " |
15 | 15 | ||
16 | RDEPENDS:${PN} += "\ | ||
17 | python3-sortedcontainers \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN}-ptest += " \ | ||
21 | python3-pytest \ | ||
22 | python3-unittest-automake-output \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | # This file tests README.md and deleted as redundant. | ||
28 | rm -f ${S}/tests/test_doc.py | ||
29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
30 | } | ||
31 | |||
16 | BBCLASSEXTEND = "native" | 32 | BBCLASSEXTEND = "native" |