diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest.inc | 41 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch (renamed from meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest_5.3.5.bb | 40 |
3 files changed, 37 insertions, 44 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc deleted file mode 100644 index 40ca9c2f13..0000000000 --- a/meta-python/recipes-devtools/python/python-pytest.inc +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "Simple powerful testing with python" | ||
2 | HOMEPAGE = "http://pytest.org" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" | ||
5 | |||
6 | SRC_URI[md5sum] = "d5ef453f723be46d93e0795f3be86c88" | ||
7 | SRC_URI[sha256sum] = "0d5fe9189a148acc3c3eb2ac8e1ac0742cb7618c084f3d228baaec0c254b318d" | ||
8 | |||
9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ | ||
10 | " | ||
11 | |||
12 | inherit update-alternatives | ||
13 | |||
14 | RDEPENDS_${PN}_class-target += " \ | ||
15 | ${PYTHON_PN}-attrs \ | ||
16 | ${PYTHON_PN}-debugger \ | ||
17 | ${PYTHON_PN}-doctest \ | ||
18 | ${PYTHON_PN}-json \ | ||
19 | ${PYTHON_PN}-pluggy \ | ||
20 | ${PYTHON_PN}-py \ | ||
21 | ${PYTHON_PN}-setuptools \ | ||
22 | ${PYTHON_PN}-six \ | ||
23 | ${PYTHON_PN}-atomicwrites \ | ||
24 | ${PYTHON_PN}-importlib-metadata \ | ||
25 | ${PYTHON_PN}-pathlib2 \ | ||
26 | ${PYTHON_PN}-wcwidth \ | ||
27 | ${PYTHON_PN}-more-itertools \ | ||
28 | ${PYTHON_PN}-packaging \ | ||
29 | " | ||
30 | |||
31 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" | ||
32 | |||
33 | ALTERNATIVE_${PN} += "py.test pytest" | ||
34 | |||
35 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" | ||
36 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" | ||
37 | |||
38 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" | ||
39 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch index c29fb12de8..c29fb12de8 100644 --- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch +++ b/meta-python/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch | |||
diff --git a/meta-python/recipes-devtools/python/python3-pytest_5.3.5.bb b/meta-python/recipes-devtools/python/python3-pytest_5.3.5.bb index eba6632a27..8dad13a9e1 100644 --- a/meta-python/recipes-devtools/python/python3-pytest_5.3.5.bb +++ b/meta-python/recipes-devtools/python/python3-pytest_5.3.5.bb | |||
@@ -1,4 +1,38 @@ | |||
1 | inherit pypi setuptools3 | 1 | SUMMARY = "Simple powerful testing with python" |
2 | require python-pytest.inc | 2 | HOMEPAGE = "http://pytest.org" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" | ||
3 | 5 | ||
4 | ALTERNATIVE_PRIORITY = "100" | 6 | SRC_URI[md5sum] = "d5ef453f723be46d93e0795f3be86c88" |
7 | SRC_URI[sha256sum] = "0d5fe9189a148acc3c3eb2ac8e1ac0742cb7618c084f3d228baaec0c254b318d" | ||
8 | |||
9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch " | ||
10 | |||
11 | inherit update-alternatives pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN}_class-target += " \ | ||
14 | ${PYTHON_PN}-attrs \ | ||
15 | ${PYTHON_PN}-debugger \ | ||
16 | ${PYTHON_PN}-doctest \ | ||
17 | ${PYTHON_PN}-json \ | ||
18 | ${PYTHON_PN}-pluggy \ | ||
19 | ${PYTHON_PN}-py \ | ||
20 | ${PYTHON_PN}-setuptools \ | ||
21 | ${PYTHON_PN}-six \ | ||
22 | ${PYTHON_PN}-atomicwrites \ | ||
23 | ${PYTHON_PN}-importlib-metadata \ | ||
24 | ${PYTHON_PN}-pathlib2 \ | ||
25 | ${PYTHON_PN}-wcwidth \ | ||
26 | ${PYTHON_PN}-more-itertools \ | ||
27 | ${PYTHON_PN}-packaging \ | ||
28 | " | ||
29 | |||
30 | ALTERNATIVE_${PN} += "py.test pytest" | ||
31 | |||
32 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" | ||
33 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" | ||
34 | |||
35 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" | ||
36 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | ||