summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-runner_6.0.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_6.0.1.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_6.0.1.bb
new file mode 100644
index 0000000000..e5e5e048bd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-runner_6.0.1.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Invoke py.test as distutils command with dependency resolution"
2HOMEPAGE = "https://pypi.org/project/pytest-runner/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
6SRC_URI[sha256sum] = "70d4739585a7008f37bf4933c013fdb327b8878a5a69fcbb3316c88882f0f49b"
7
8inherit pypi python_setuptools_build_meta
9
10DEPENDS += " \
11 python3-setuptools-scm-native"
12
13RDEPENDS:${PN} = "python3-setuptools python3-debugger python3-json python3-io"
14
15BBCLASSEXTEND = "native nativesdk"