diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-gevent.inc | 10 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-gevent_1.4.0.bb (renamed from meta-python/recipes-devtools/python/python3-gevent_1.2.2.bb) | 1 |
3 files changed, 32 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent.inc b/meta-python/recipes-devtools/python/python-gevent.inc index 13513f2192..bc89d104af 100644 --- a/meta-python/recipes-devtools/python/python-gevent.inc +++ b/meta-python/recipes-devtools/python/python-gevent.inc | |||
@@ -4,8 +4,9 @@ a high-level synchronous API on top of the libevent event loop." | |||
4 | HOMEPAGE = "http://www.gevent.org" | 4 | HOMEPAGE = "http://www.gevent.org" |
5 | LICENSE = "MIT & Python-2.0 & BSD" | 5 | LICENSE = "MIT & Python-2.0 & BSD" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ |
7 | file://NOTICE;md5=5966cd2c6582656d28ab3c33da3860f8 \ | 7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ |
8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347" | 8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ |
9 | " | ||
9 | DEPENDS += "libevent" | 10 | DEPENDS += "libevent" |
10 | DEPENDS += "${PYTHON_PN}-greenlet" | 11 | DEPENDS += "${PYTHON_PN}-greenlet" |
11 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ | 12 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ |
@@ -17,10 +18,11 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:" | |||
17 | 18 | ||
18 | SRC_URI_append = " \ | 19 | SRC_URI_append = " \ |
19 | file://libev-conf.patch;patch=1;pnum=1 \ | 20 | file://libev-conf.patch;patch=1;pnum=1 \ |
21 | file://0002-setup.py-do-not-query-for-include-dir.patch \ | ||
20 | " | 22 | " |
21 | 23 | ||
22 | SRC_URI[md5sum] = "7f0baf355384fe5ff2ecf66853422554" | 24 | SRC_URI[md5sum] = "6b9dd98917061803d9158e5258b8f412" |
23 | SRC_URI[sha256sum] = "4791c8ae9c57d6f153354736e1ccab1e2baf6c8d9ae5a77a9ac90f41e2966b2d" | 25 | SRC_URI[sha256sum] = "1eb7fa3b9bd9174dfe9c3b59b7a09b768ecd496debfc4976a9530a3e15c990d1" |
24 | 26 | ||
25 | # The python-gevent has no autoreconf ability | 27 | # The python-gevent has no autoreconf ability |
26 | # and the logic for detecting a cross compile is flawed | 28 | # and the logic for detecting a cross compile is flawed |
diff --git a/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch b/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch new file mode 100644 index 0000000000..7536b71a69 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From a53ed6b2f967a5f95e69d51cad3f8c120d7df65b Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Thu, 7 Feb 2019 15:21:15 +0100 | ||
4 | Subject: [PATCH] setup.py: do not query for include dir | ||
5 | |||
6 | As this will return the native python directory erroneously. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe-core specific] | ||
9 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
10 | --- | ||
11 | setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 86d6c5a..5d22291 100755 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -52,7 +52,7 @@ from _setupares import ARES | ||
19 | # Get access to the greenlet header file. | ||
20 | # The sysconfig dir is not enough if we're in a virtualenv | ||
21 | # See https://github.com/pypa/pip/issues/4610 | ||
22 | -include_dirs = [sysconfig.get_path("include")] | ||
23 | +include_dirs = [] | ||
24 | venv_include_dir = os.path.join(sys.prefix, 'include', 'site', | ||
25 | 'python' + sysconfig.get_python_version()) | ||
26 | venv_include_dir = os.path.abspath(venv_include_dir) | ||
diff --git a/meta-python/recipes-devtools/python/python3-gevent_1.2.2.bb b/meta-python/recipes-devtools/python/python3-gevent_1.4.0.bb index 1f172e5868..df688e4240 100644 --- a/meta-python/recipes-devtools/python/python3-gevent_1.2.2.bb +++ b/meta-python/recipes-devtools/python/python3-gevent_1.4.0.bb | |||
@@ -1,3 +1,2 @@ | |||
1 | require python-gevent.inc | 1 | require python-gevent.inc |
2 | inherit setuptools3 | 2 | inherit setuptools3 |
3 | |||