diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 25 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-zopeinterface.inc b/meta-python/recipes-devtools/python/python-zopeinterface.inc new file mode 100644 index 0000000000..1ea6114634 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-zopeinterface.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Interface definitions for Zope products" | ||
2 | LICENSE = "ZPL-2.1" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46" | ||
4 | |||
5 | SRC_URI[md5sum] = "ba3f32eacaea66094b7e2ae2788cec89" | ||
6 | SRC_URI[sha256sum] = "8780ef68ca8c3fe1abb30c058a59015129d6e04a6b02c2e56b9c7de6078dfa88" | ||
7 | |||
8 | PYPI_PACKAGE = "zope.interface" | ||
9 | |||
10 | PACKAGES =. "${PN}-test " | ||
11 | |||
12 | RPROVIDES_${PN} += "zope-interfaces" | ||
13 | |||
14 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug" | ||
15 | FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c" | ||
16 | FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt" | ||
17 | FILES_${PN}-test += " \ | ||
18 | ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \ | ||
19 | ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \ | ||
20 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb index 8ad1250822..1bdfd4d376 100644 --- a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb +++ b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb | |||
@@ -1,23 +1,4 @@ | |||
1 | SUMMARY = "Interface definitions for Zope products" | ||
2 | LICENSE = "ZPL-2.1" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46" | ||
4 | |||
5 | SRC_URI[md5sum] = "ba3f32eacaea66094b7e2ae2788cec89" | ||
6 | SRC_URI[sha256sum] = "8780ef68ca8c3fe1abb30c058a59015129d6e04a6b02c2e56b9c7de6078dfa88" | ||
7 | |||
8 | PYPI_PACKAGE = "zope.interface" | ||
9 | inherit pypi setuptools | 1 | inherit pypi setuptools |
10 | 2 | require python-zopeinterface.inc | |
11 | PACKAGES =. "${PN}-test " | ||
12 | |||
13 | RPROVIDES_${PN} += "zope-interfaces" | ||
14 | 3 | ||
15 | RDEPENDS_${PN}-test += "python-unittest python-doctest" | 4 | RDEPENDS_${PN}-test += "python-unittest python-doctest" |
16 | |||
17 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug" | ||
18 | FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c" | ||
19 | FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt" | ||
20 | FILES_${PN}-test += " \ | ||
21 | ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \ | ||
22 | ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \ | ||
23 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb b/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb new file mode 100644 index 0000000000..be11858d34 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-zopeinterface.inc | ||
3 | |||
4 | RDEPENDS_${PN}-test += "python3-unittest python3-doctest" | ||