diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask_3.1.0.bb | 12 |
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask/run-ptest b/meta-python/recipes-devtools/python/python3-flask/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-flask/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb b/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb index 9b10089c9e..4d1d2d12e6 100644 --- a/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb | |||
@@ -8,11 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ffeffa59c90c9c4a033c7574f8f3fb75" | |||
8 | 8 | ||
9 | SRC_URI[sha256sum] = "5f873c5184c897c8d9d1b05df1e3d01b14910ce69607a117bd3277098a5836ac" | 9 | SRC_URI[sha256sum] = "5f873c5184c897c8d9d1b05df1e3d01b14910ce69607a117bd3277098a5836ac" |
10 | 10 | ||
11 | SRC_URI += " \ | 11 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | inherit pypi python_setuptools_build_meta ptest | ||
16 | 12 | ||
17 | CLEANBROKEN = "1" | 13 | CLEANBROKEN = "1" |
18 | 14 | ||
@@ -27,10 +23,4 @@ RDEPENDS:${PN} = " \ | |||
27 | 23 | ||
28 | RDEPENDS:${PN}-ptest += "\ | 24 | RDEPENDS:${PN}-ptest += "\ |
29 | python3-asgiref \ | 25 | python3-asgiref \ |
30 | python3-pytest \ | ||
31 | python3-unittest-automake-output \ | ||
32 | " | 26 | " |
33 | do_install_ptest() { | ||
34 | install -d ${D}${PTEST_PATH}/tests | ||
35 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
36 | } | ||