summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproj/rpath.patch18
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproj_3.6.1.bb2
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch b/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch
new file mode 100644
index 0000000000..347996a808
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyproj/rpath.patch
@@ -0,0 +1,18 @@
1Description: Don't set RPATH in libraries.
2Author: Bas Couwenberg <sebastic@debian.org>
3Forwarded: not-needed
4
5Upstream-Status: Inappropriate [OE-Specific]
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7--- a/setup.py
8+++ b/setup.py
9@@ -194,9 +194,6 @@ def get_extension_modules():
10 ext_options = {
11 "include_dirs": include_dirs,
12 "library_dirs": library_dirs,
13- "runtime_library_dirs": (
14- library_dirs if os.name != "nt" and sys.platform != "cygwin" else None
15- ),
16 "libraries": get_libraries(library_dirs),
17 }
18 # setup cythonized modules
diff --git a/meta-python/recipes-devtools/python/python3-pyproj_3.6.1.bb b/meta-python/recipes-devtools/python/python3-pyproj_3.6.1.bb
index 799096d6fa..b5403069bb 100644
--- a/meta-python/recipes-devtools/python/python3-pyproj_3.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyproj_3.6.1.bb
@@ -6,6 +6,8 @@ DEPENDS:append:class-target = " python3-cython-native proj-native"
6 6
7inherit pypi python_setuptools_build_meta 7inherit pypi python_setuptools_build_meta
8 8
9SRC_URI += "file://rpath.patch"
10
9SRC_URI[sha256sum] = "44aa7c704c2b7d8fb3d483bbf75af6cb2350d30a63b144279a09b75fead501bf" 11SRC_URI[sha256sum] = "44aa7c704c2b7d8fb3d483bbf75af6cb2350d30a63b144279a09b75fead501bf"
10 12
11RDEPENDS:${PN} = " \ 13RDEPENDS:${PN} = " \