summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-trustme/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trustme/run-ptest b/meta-python/recipes-devtools/python/python3-trustme/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-trustme/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-trustme/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb b/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
index e925712f36..ac03bce2b0 100644
--- a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
@@ -20,9 +20,10 @@ RDEPENDS:${PN} += " \
20" 20"
21 21
22RDEPENDS:${PN}-ptest += " \ 22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \ 23 python3-pyasn1-modules \
24 ${PYTHON_PN}-service-identity \ 24 python3-pytest \
25 ${PYTHON_PN}-pyasn1-modules \ 25 python3-service-identity \
26 python3-unittest-automake-output \
26" 27"
27 28
28do_install_ptest() { 29do_install_ptest() {