summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyjwt.inc17
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb18
2 files changed, 16 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyjwt.inc b/meta-python/recipes-devtools/python/python-pyjwt.inc
deleted file mode 100644
index 9b8938530a..0000000000
--- a/meta-python/recipes-devtools/python/python-pyjwt.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "JSON Web Token implementation in Python"
2SUMMARY = "JSON Web Token implementation in Python"
3DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
4 Original implementation was written by https://github.com/progrium"
5HOMEPAGE = "http://github.com/jpadilla/pyjwt"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
8
9SRC_URI[md5sum] = "a4712f980c008696e13e09504120b2a0"
10SRC_URI[sha256sum] = "8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96"
11
12PYPI_PACKAGE = "PyJWT"
13inherit pypi
14
15RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
16
17BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb b/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
index dc16d22825..d2f7be46cf 100644
--- a/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
@@ -1,2 +1,16 @@
1require python-pyjwt.inc 1SUMMARY = "JSON Web Token implementation in Python"
2inherit setuptools3 2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
7
8SRC_URI[md5sum] = "a4712f980c008696e13e09504120b2a0"
9SRC_URI[sha256sum] = "8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96"
10
11PYPI_PACKAGE = "PyJWT"
12inherit pypi setuptools3
13
14RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
15
16BBCLASSEXTEND = "native nativesdk"