summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_4.4.1.bb13
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard/run-ptest b/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.4.1.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.4.1.bb
index 8b2604e4a2..45b32f5120 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.4.1.bb
@@ -5,11 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5 5
6SRC_URI[sha256sum] = "0d22a89d00b453b47c49875f42b6601b961757541a2e1e0ef517b6e24213c21b" 6SRC_URI[sha256sum] = "0d22a89d00b453b47c49875f42b6601b961757541a2e1e0ef517b6e24213c21b"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest-python-pytest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13 9
14RDEPENDS:${PN} += " \ 10RDEPENDS:${PN} += " \
15 python3-core \ 11 python3-core \
@@ -19,18 +15,11 @@ RDEPENDS:${PN} += " \
19" 15"
20 16
21RDEPENDS:${PN}-ptest += " \ 17RDEPENDS:${PN}-ptest += " \
22 python3-pytest \
23 python3-typing-extensions \ 18 python3-typing-extensions \
24 python3-unittest-automake-output \
25 python3-unixadmin \ 19 python3-unixadmin \
26 python3-mypy \ 20 python3-mypy \
27" 21"
28 22
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}
33
34DEPENDS += "\ 23DEPENDS += "\
35 python3-distutils-extra-native \ 24 python3-distutils-extra-native \
36 python3-setuptools-scm-native \ 25 python3-setuptools-scm-native \