summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch36
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb16
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch
new file mode 100644
index 0000000000..7b81203807
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch
@@ -0,0 +1,36 @@
1From 4348c72877e049804c7cdb7eec7a6bcd7ac2ea1d Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Wed, 11 May 2022 13:21:30 +0200
4Subject: [PATCH] setup: don't use setuptools-markdown
5
6This project is deprecated and irrelevant for the functionality of
7eth-keyfile. We don't support it in meta-python so just drop it from
8the dependencies.
9
10Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
11---
12 setup.py | 2 --
13 1 file changed, 2 deletions(-)
14
15diff --git a/setup.py b/setup.py
16index cbb7f4c..7702aa4 100644
17--- a/setup.py
18+++ b/setup.py
19@@ -51,14 +51,12 @@ setup(
20 "A library for handling the encrypted keyfiles used to store ethereum "
21 "private keys."
22 ),
23- long_description_markdown_filename='README.md',
24 author='Piper Merriam',
25 author_email='pipermerriam@gmail.com',
26 url='https://github.com/ethereum/eth-keyfile',
27 include_package_data=True,
28 install_requires=install_requires,
29 extras_require=deps,
30- setup_requires=['setuptools-markdown'],
31 py_modules=['eth_keyfile'],
32 license="MIT",
33 zip_safe=False,
34--
352.34.1
36
diff --git a/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb b/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb
new file mode 100644
index 0000000000..9477632e2f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb
@@ -0,0 +1,16 @@
1SUMMARY = "A library for handling the encrypted keyfiles used to store ethereum private keys."
2HOMEPAGE = "https://github.com/ethereum/eth-keyfile"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2beaef1b1764f4d6b46084c885b4bcad"
6
7SRC_URI[sha256sum] = "d30597cdecb8ccd3b56bb275cd86fcdc7a279f86eafa92ddc49f66512f0bff67"
8SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 python3-eth-keys \
14 python3-pycryptodome \
15 python3-setuptools \
16"