summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-posix-ipc/0001-Use-default-cc-from-environment-variable.patch45
-rw-r--r--meta-python/recipes-devtools/python/python3-posix-ipc_1.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-posix-ipc_1.1.1.bb)6
2 files changed, 2 insertions, 49 deletions
diff --git a/meta-python/recipes-devtools/python/python3-posix-ipc/0001-Use-default-cc-from-environment-variable.patch b/meta-python/recipes-devtools/python/python3-posix-ipc/0001-Use-default-cc-from-environment-variable.patch
deleted file mode 100644
index 86829869a2..0000000000
--- a/meta-python/recipes-devtools/python/python3-posix-ipc/0001-Use-default-cc-from-environment-variable.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 2db4d9974052e28f25252b3204a73dd25de1dd89 Mon Sep 17 00:00:00 2001
2From: Gyorgy Sarvari <skandigraun@gmail.com>
3Date: Sat, 25 Jan 2025 13:09:00 +0100
4Subject: [PATCH] Use default cc from environment variable
5
6In case the system uses a custom c compiler instead of cc
7(e.g. for cross-compiling), probing system features can
8fail or can misidentify the features due to the incorrect C compiler.
9
10Instead of using only "cc" for probing features, check if the CC environment
11variable has a custom C compiler set. If it is present, use that instead of
12"cc". If it is not present, fall back to "cc".
13
14Upstream-Status: Submitted [https://github.com/osvenskan/posix_ipc/pull/56]
15---
16 prober.py | 7 +++++--
17 1 file changed, 5 insertions(+), 2 deletions(-)
18
19diff --git a/prober.py b/prober.py
20index 48432b7..ace6d3b 100644
21--- a/prober.py
22+++ b/prober.py
23@@ -52,14 +52,17 @@ def print_bad_news(value_name, default):
24 def does_build_succeed(filename, linker_options=""):
25 # Utility function that returns True if the file compiles and links
26 # successfully, False otherwise.
27- # Two things to note here --
28+ # Three things to note here --
29 # - If there's a linker option like -lrt, it needs to come *after*
30 # the specification of the C file or linking will fail on Ubuntu 11.10
31 # (maybe because of the gcc version?)
32 # - Some versions of Linux place the sem_xxx() functions in libpthread.
33 # Rather than testing whether or not it's needed, I just specify it
34 # everywhere since it's harmless to specify it when it's not needed.
35- cmd = "cc -Wall -o ./prober/foo ./prober/%s %s -lpthread" % (filename, linker_options)
36+ # - In case the used C compiler is not cc, take it from the CC environment
37+ # variable
38+ cc = os.getenv("CC", "cc")
39+ cmd = "%s -Wall -o ./prober/foo ./prober/%s %s -lpthread" % (cc, filename, linker_options)
40
41 p = subprocess.Popen(cmd, shell=True, stdout=STDOUT, stderr=STDERR)
42
43--
442.48.1
45
diff --git a/meta-python/recipes-devtools/python/python3-posix-ipc_1.1.1.bb b/meta-python/recipes-devtools/python/python3-posix-ipc_1.2.0.bb
index c29996de53..29e1b35122 100644
--- a/meta-python/recipes-devtools/python/python3-posix-ipc_1.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-posix-ipc_1.2.0.bb
@@ -2,13 +2,11 @@ DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queue
2HOMEPAGE = "https://semanchuk.com/philip/posix_ipc/" 2HOMEPAGE = "https://semanchuk.com/philip/posix_ipc/"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=513d94a7390d4d72f3475e2d45c739b5" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1a4f3bd729df04bf68f66ef877e9c7c9"
6 6
7PYPI_PACKAGE = "posix_ipc" 7PYPI_PACKAGE = "posix_ipc"
8UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" 8UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
9 9
10SRC_URI[sha256sum] = "e2456ba0cfb2ee5ba14121450e8d825b3c4a1461fca0761220aab66d4111cbb7" 10SRC_URI[sha256sum] = "b7444e2703c156b3cb9fcb568e85d716232f3e78f04529ebc881cfb2aedb3838"
11
12SRC_URI += "file://0001-Use-default-cc-from-environment-variable.patch"
13 11
14inherit setuptools3 pypi 12inherit setuptools3 pypi