diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-trustme/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-trustme_1.2.1.bb | 13 |
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trustme/run-ptest b/meta-python/recipes-devtools/python/python3-trustme/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-trustme/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-trustme_1.2.1.bb b/meta-python/recipes-devtools/python/python3-trustme_1.2.1.bb index 519c6b8922..bdf5a494a7 100644 --- a/meta-python/recipes-devtools/python/python3-trustme_1.2.1.bb +++ b/meta-python/recipes-devtools/python/python3-trustme_1.2.1.bb | |||
@@ -6,11 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fb59582a4d7ecbb79dfeefa0f69932e1" | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "6528ba2bbc7f2db41f33825c8dd13e3e3eb9d334ba0f909713c8c3139f4ae47f" | 7 | SRC_URI[sha256sum] = "6528ba2bbc7f2db41f33825c8dd13e3e3eb9d334ba0f909713c8c3139f4ae47f" |
8 | 8 | ||
9 | inherit pypi python_hatchling python_setuptools_build_meta ptest | 9 | inherit pypi python_hatchling python_setuptools_build_meta ptest-python-pytest |
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | 10 | ||
15 | RDEPENDS:${PN} += " \ | 11 | RDEPENDS:${PN} += " \ |
16 | python3-cryptography \ | 12 | python3-cryptography \ |
@@ -23,13 +19,6 @@ RDEPENDS:${PN}-ptest += " \ | |||
23 | python3-attrs \ | 19 | python3-attrs \ |
24 | python3-pyopenssl \ | 20 | python3-pyopenssl \ |
25 | python3-pyasn1-modules \ | 21 | python3-pyasn1-modules \ |
26 | python3-pytest \ | ||
27 | python3-service-identity \ | 22 | python3-service-identity \ |
28 | python3-six \ | 23 | python3-six \ |
29 | python3-unittest-automake-output \ | ||
30 | " | 24 | " |
31 | |||
32 | do_install_ptest() { | ||
33 | install -d ${D}${PTEST_PATH}/tests | ||
34 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
35 | } | ||